#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)"
Local $sString = "section aaa:" & @CRLF & _
" some values" & @CRLF & _
" value 55" & @CRLF & _
"section eee:" & @CRLF & _
" some :values" & @CRLF & _
" value 5" & @CRLF & _
"section bbb:" & @CRLF & _
" more values" & @CRLF & _
" value 6" & @CRLF & _
"section ccc:" & @CRLF & _
" more values" & @CRLF & _
" value 7" & @CRLF & _
"section aaaa:" & @CRLF & _
" some values" & @CRLF & _
" value 5" & @CRLF & _
"section bbbb:" & @CRLF & _
" more values" & @CRLF & _
" value 6" & @CRLF & _
"section cccc:" & @CRLF & _
" more values" & @CRLF & _
" value 7"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")