package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)`)
var str = `section aaa:
some values
value 55
section eee:
some :values
value 5
section bbb:
more values
value 6
section ccc:
more values
value 7
section aaaa:
some values
value 5
section bbbb:
more values
value 6
section cccc:
more values
value 7`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}