import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^section ([^:\\n]+):.*\\n( +.*\\n)*( +value 5\\b)";
final String string = "section aaa:\n"
+ " some values\n"
+ " value 55\n"
+ "section eee:\n"
+ " some :values\n"
+ " value 5\n"
+ "section bbb:\n"
+ " more values\n"
+ " value 6\n"
+ "section ccc:\n"
+ " more values\n"
+ " value 7\n"
+ "section aaaa:\n"
+ " some values\n"
+ " value 5\n"
+ "section bbbb:\n"
+ " more values\n"
+ " value 6\n"
+ "section cccc:\n"
+ " more values\n"
+ " value 7";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}