use strict;
my $str = 'section aaa:
some values
value 55
section eee:
some :values
value 5
section bbb:
more values
value 6
section ccc:
more values
value 7
section aaaa:
some values
value 5
section bbbb:
more values
value 6
section cccc:
more values
value 7';
my $regex = qr/^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}