using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)";
string input = @"section aaa:
some values
value 55
section eee:
some :values
value 5
section bbb:
more values
value 6
section ccc:
more values
value 7
section aaaa:
some values
value 5
section bbbb:
more values
value 6
section cccc:
more values
value 7";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}