import Foundation
let pattern = #"^section ([^:\n]+):.*\n( +.*\n)*( +value 5\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
section aaa:
some values
value 55
section eee:
some :values
value 5
section bbb:
more values
value 6
section ccc:
more values
value 7
section aaaa:
some values
value 5
section bbbb:
more values
value 6
section cccc:
more values
value 7
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)