#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<span class=\".*?(?:(id=[^>]*))?>\s*([^<]*)\s*"
Local $sString = " <span class="price">£ 343" & @CRLF & _
" </span>" & @CRLF & _
" Some html code" & @CRLF & _
" <span class="price" id="old-price-22898">£ 343</span>" & @CRLF & _
" </p><p class="special-price">" & @CRLF & _
" <span class="price" id="product-price-22898">" & @CRLF & _
" £ 274 " & @CRLF & _
" </span>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")