import re
regex = re.compile(r"<span class=\".*?(?:(id=[^>]*))?>\s*([^<]*)\s*")
test_str = (" <span class=\"price\">£ 343\n"
" </span>\n"
" Some html code\n"
" <span class=\"price\" id=\"old-price-22898\">£ 343</span>\n"
" </p><p class=\"special-price\">\n"
" <span class=\"price\" id=\"product-price-22898\">\n"
" £ 274 \n"
" </span>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")