import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span class=\\\".*?(?:(id=[^>]*))?>\\s*([^<]*)\\s*";
final String string = " <span class=\"price\">£ 343\n"
+ " </span>\n"
+ " Some html code\n"
+ " <span class=\"price\" id=\"old-price-22898\">£ 343</span>\n"
+ " </p><p class=\"special-price\">\n"
+ " <span class=\"price\" id=\"product-price-22898\">\n"
+ " £ 274 \n"
+ " </span>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}