const regex = /<span class=\".*?(?:(id=[^>]*))?>\s*([^<]*)\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span class=\\".*?(?:(id=[^>]*))?>\\s*([^<]*)\\s*', 'g')
const str = ` <span class="price">£ 343
</span>
Some html code
<span class="price" id="old-price-22898">£ 343</span>
</p><p class="special-price">
<span class="price" id="product-price-22898">
£ 274
</span>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}