// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<span class=\".*?(?:(id=[^>]*))?>\s*([^<]*)\s*"#).unwrap();
let string = " <span class=\"price\">£ 343
</span>
Some html code
<span class=\"price\" id=\"old-price-22898\">£ 343</span>
</p><p class=\"special-price\">
<span class=\"price\" id=\"product-price-22898\">
£ 274
</span>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}