$re = '/<span class=\".*?(?:(id=[^>]*))?>\s*([^<]*)\s*/';
$str = ' <span class="price">£ 343
</span>
Some html code
<span class="price" id="old-price-22898">£ 343</span>
</p><p class="special-price">
<span class="price" id="product-price-22898">
£ 274
</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);