using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=\"".*?(?:(id=[^>]*))?>\s*([^<]*)\s*";
string input = @" <span class=""price"">£ 343
</span>
Some html code
<span class=""price"" id=""old-price-22898"">£ 343</span>
</p><p class=""special-price"">
<span class=""price"" id=""product-price-22898"">
£ 274
</span>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}