package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<span class=\".*?(?:(id=[^>]*))?>\s*([^<]*)\s*`)
var str = ` <span class="price">£ 343
</span>
Some html code
<span class="price" id="old-price-22898">£ 343</span>
</p><p class="special-price">
<span class="price" id="product-price-22898">
£ 274
</span>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}