package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("),(\s*})`)
var str = `[{
"s1":"s2",
"s2":"s3",
},
{
"d1":"d2",
"d3":"d4",
},`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}