$re = '/("),(\s*})/m';
$str = '[{
"s1":"s2",
"s2":"s3",
},
{
"d1":"d2",
"d3":"d4",
},';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;