import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"),(\\s*\\})";
final String string = "[{\n"
+ " \"s1\":\"s2\",\n"
+ " \"s2\":\"s3\",\n"
+ " },\n"
+ " {\n"
+ " \"d1\":\"d2\",\n"
+ " \"d3\":\"d4\",\n"
+ " },";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}