import re
regex = re.compile(r"(\"),(\s*})", flags=re.MULTILINE)
test_str = ("[{\n"
" \"s1\":\"s2\",\n"
" \"s2\":\"s3\",\n"
" },\n"
" {\n"
" \"d1\":\"d2\",\n"
" \"d3\":\"d4\",\n"
" },")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)