# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[.\w]+\.(\w+)/$1/g;t' <<< "name.space.class
name.space.class<other.name.space.class1>
name.space.class<other.name.space.class1, shortSpace.class2>
class
class2
class3
Applet.Repository"