#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[.\w]+\.(\w+)"
Local $sString = "name.space.class" & @CRLF & _
"name.space.class<other.name.space.class1>" & @CRLF & _
"name.space.class<other.name.space.class1, shortSpace.class2>" & @CRLF & _
"class" & @CRLF & _
"class2" & @CRLF & _
"class3" & @CRLF & _
"Applet.Repository"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)