const regex = /[.\w]+\.(\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[.\\w]+\\.(\\w+)', 'g')
const str = `name.space.class
name.space.class<other.name.space.class1>
name.space.class<other.name.space.class1, shortSpace.class2>
class
class2
class3
Applet.Repository`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);