import re
regex = re.compile(r"[.\w]+\.(\w+)")
test_str = ("name.space.class\n"
"name.space.class<other.name.space.class1>\n"
"name.space.class<other.name.space.class1, shortSpace.class2>\n"
"class\n"
"class2\n"
"class3\n"
"Applet.Repository")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)