use strict;
my $str = 'name.space.class
name.space.class<other.name.space.class1>
name.space.class<other.name.space.class1, shortSpace.class2>
class
class2
class3
Applet.Repository';
my $regex = qr/[.\w]+\.(\w+)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";