re = /[.\w]+\.(\w+)/
str = 'name.space.class
name.space.class<other.name.space.class1>
name.space.class<other.name.space.class1, shortSpace.class2>
class
class2
class3
Applet.Repository'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result