#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)([A-Za-z0-9]+)\.HasNext"
Local $sString = "for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {"
Local $sSubst = "!\1.IsEnd"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)