using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Za-z0-9]+)\.HasNext";
string substitution = @"!\1.IsEnd";
string input = @"for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}