const regex = /([A-Za-z0-9]+)\.HasNext/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Za-z0-9]+)\\.HasNext', 'gm')
const str = `for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {`;
const subst = `!\1.IsEnd`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);