// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([A-Za-z0-9]+)\.HasNext").unwrap();
let string = "for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {";
let substitution = "!\\1.IsEnd";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}