import Foundation
let pattern = #"([A-Za-z0-9]+)\.HasNext"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"!\1.IsEnd"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)