package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Za-z0-9]+)\.HasNext`)
var str = `for (local tile = tileList.Begin(); tileList.HasNext(); tile = tileList.Next()) {`
var substitution = "!\1.IsEnd"
fmt.Println(re.ReplaceAllString(str, substitution))
}