# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\(acetyl\)(.)/(\1)/gm;t' <<< "(acetyl)RKJOEQLKQ
LDFEION(acetyl)EFNEOW
"