const regex = /\(acetyl\)(.)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(acetyl\\)(.)', 'gm')
const str = `(acetyl)RKJOEQLKQ
LDFEION(acetyl)EFNEOW
`;
const subst = `(\1)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);