# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<!:)[^\p{L}\p{N}])\1+/$1/gu;t' <<< "Hello... how are you!!?? I''m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<
My ////favorite//// site is http://///example.com!!!!!!!"