use strict;
my $str = 'Hello... how are you!!?? I\'\'m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<
My ////favorite//// site is http://///example.com!!!!!!!';
my $regex = qr~((?<!:)[^\p{L}\p{N}])\1+~up;
my $subst = '$1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";