const regex = new RegExp('((?<!:)[^\\p{L}\\p{N}])\\1+', 'gu')
const str = `Hello... how are you!!?? I''m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<
My ////favorite//// site is http://///example.com!!!!!!!`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);