$re = '~((?<!:)[^\p{L}\p{N}])\1+~u';
$str = 'Hello... how are you!!?? I\'\'m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<
My ////favorite//// site is http://///example.com!!!!!!!';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;