import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<!:)[^\\p{L}\\p{N}])\\1+";
final String string = "Hello... how are you!!?? I''m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<\n"
+ "My ////favorite//// site is http://///example.com!!!!!!!";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}