re = /((?<!:)[^\p{L}\p{N}])\1+/
str = 'Hello... how are you!!?? I\'\'m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<
My ////favorite//// site is http://///example.com!!!!!!!'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result