import re
regex = re.compile(r"((?<!:)[^\p{L}\p{N}])\1+", flags=re.UNICODE)
test_str = ("Hello... how are you!!?? I''m bored!!----!!!&&&&&^^^^%%%(()))((<<<<<\n"
"My ////favorite//// site is http://///example.com!!!!!!!")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)