using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?(?:\d*(?:,\d{3})*|\d*),?$";
string input = @"Valid Match :
1,000
111
100,
123111,111
Invalid Match :
-,1
1,,,,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}