// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^-?(?:\d*(?:,\d{3})*|\d*),?$").unwrap();
let string = "Valid Match :
1,000
111
100,
123111,111
Invalid Match :
-,1
1,,,,";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}