$re = '/^-?(?:\d*(?:,\d{3})*|\d*),?$/m';
$str = 'Valid Match :
1,000
111
100,
123111,111
Invalid Match :
-,1
1,,,,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);