import re
regex = re.compile(r"^-?(?:\d*(?:,\d{3})*|\d*),?$", flags=re.MULTILINE)
test_str = ("Valid Match : \n"
"1,000\n"
"111\n\n"
"100,\n"
"123111,111\n"
"Invalid Match : \n"
"-,1\n"
"1,,,,")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")