const regex = /^-?(?:\d*(?:,\d{3})*|\d*),?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^-?(?:\\d*(?:,\\d{3})*|\\d*),?$', 'gm')
const str = `Valid Match :
1,000
111
100,
123111,111
Invalid Match :
-,1
1,,,,`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}