package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^-?(?:\d*(?:,\d{3})*|\d*),?$`)
var str = `Valid Match :
1,000
111
100,
123111,111
Invalid Match :
-,1
1,,,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}