re = /^-?(?:\d*(?:,\d{3})*|\d*),?$/m
str = 'Valid Match :
1,000
111
100,
123111,111
Invalid Match :
-,1
1,,,,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end