import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^-?(?:\\d*(?:,\\d{3})*|\\d*),?$";
final String string = "Valid Match : \n"
+ "1,000\n"
+ "111\n\n"
+ "100,\n"
+ "123111,111\n"
+ "Invalid Match : \n"
+ "-,1\n"
+ "1,,,,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}