#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\b((?:ri)?comprat)[aeio]\b"
Local $sString = "ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati"
Local $sSubst = "\1+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)