re = /\b((?:ri)?comprat)[aeio]\b/m
str = 'ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati'
subst = '\\1+'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result