$re = '/\b((?:ri)?comprat)[aeio]\b/m';
$str = 'ricomprate uno comprato comprata due comprate ricomprate tre ricomprato comprati';
$subst = "\1+";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;